Fix: Grunt Imagemin GLIBC_2.15 not found

I was using Grunt to build my web app on my VPS. I use the “grunt-contrib-imagemin” package which minifies images. It all seemed to work fine in Nitrous whatsoever. Turns out I get a weird error that says “‘GLIBC_2.15’ not found”. I looked in the npm log and it seems like the PNG package could have not been built, a library was missing. To fix I ran this command: sudo apt-get install libpng-dev

December 12, 2014 · 1 min · 73 words · Gian Sass